Knowledgebase: Microsoft Products
[QODBC-ALL] How to create sp_reports using Microsoft Excel
Posted by Jack - QODBC Support on 14 February 2018 11:55 AM

How to create sp_reports using Microsoft Excel

How to extract sp_reports using Microsoft Excel

Open Microsoft Query in Excel

Open Microsoft Excel, get external data from Microsoft Query via Data Menu -> "Get Data -> From Other Sources->From Microsoft Query" as below:

It will take some time to get the DSN list:

In the "Choose Data Source" Window, Select the QuickBooks Data DSN you set up with the QODBC driver. This is one of our pre-installed DSN names or one that you have created.

Note: Uncheck option "Use Query Wizard to Created/edit Queries" since we do not need to import any tables here.

Note: For using QuickBooks Online report, you need to Select the QuickBooks Online Data DSN.

Close the "Add Tables" window by clicking the "Close" button.

Press "SQL" button to input your own sp_report query as below, here we take a BalanceSheetDetail report as an example:

sp_report BalanceSheetDetail parameters DateMacro = 'ThisMonthToDate'

Click "OK" button to close warning message:

Press Execute button to get results in Microsoft Query:

Return Records to Excel Spreadsheet

To return records to Excel Spreadsheet, select Menu File -> Return Data to Microsoft Excel.

Also, Refer:

How to use the QuickBooks Reporting Engine with QODBC

How to use the QuickBooks Reporting Engine with QODBC Online

(0 vote(s))
Helpful
Not helpful

Comments (0)
Post a new comment
 
 
Full Name:
Email:
Comments:
CAPTCHA Verification 
 
Please complete the captcha below (we use this to prevent automated submissions).