Knowledgebase
[QODBC-Online] Unable to connect to QuickBooks Online using QODBC Online
Posted by Jack - QODBC Support on 21 December 2017 11:21 AM

Troubleshooting - Unable to connect to QuickBooks Online using QODBC Online - Update QODBC Online to v18.0.0.325 or above

Intuit requires an upgrade to TLS 1.2  in order to align with industry best practices for security and data integrity.

On July 31, 2017, Intuit disables the TLS 1.0 and TLS 1.1 encryption protocol, which will prevent apps still using them from accessing Intuit and QuickBooks APIs and Services.

Additionally, Intuit requires an upgrade to TLS 1.2 by December 31, 2017. On December 31, 2017, Intuit will disable the TLS 1.1 encryption protocol.

Refer: Intuit's News:

TLS 1.0 and 1.1 Disablement for the Intuit Developer Group

&

Upgrading your apps to support TLS 1.2

The current version of the .NET SDK (v3.2.1) uses .NET Framework 4.0. We are migrating the .NET SDK (.NET SDK for QuickBooks Online V3.2.1) to Framework 4.6.1 to support TLS 1.2 proactively.

Update from Intuit (Dec 21, 2017) - "Based on developer feedback, we are extending the deadline to March 31, 2018." 

Update from Intuit (March 31, 2018) - "Based on developer feedback, we are extending the deadline to September 20, 2018." 

 

What do you need to do?:

After September 20, 2018, You may not be able to connect QuickBooks Online using QODBC Online old version.

We have already implemented requested .NET Framework changes in QODBC Online V18.0.0.325.

You need to download & install QODBC Online latest version for connecting QuickBooks Online after September 20, 2018.

You can download QODBC Online latest version by clicking here.

For the System requirement details of QODBC Online click here.

(0 vote(s))
Helpful
Not helpful

Comments (0)
Post a new comment
 
 
Full Name:
Email:
Comments:
CAPTCHA Verification 
 
Please complete the captcha below (we use this to prevent automated submissions).