Knowledgebase
[QODBC-Desktop] Troubleshooting - QRemote does not work with IIS
Posted by Jack - QODBC Support on 08 October 2015 09:11 AM

Troubleshooting - QRemote does not work with IIS

Problem Description:

We’ve been having steady success with QODBC for a good while. We’re running QB on a VM and our custom application that queries it on another VM, both VMs are Server 2012.

All was well with our integration until I changed, by necessity, the setting for Enable 32-bit Applications. Once I made it True, the integration through QRemote does not work. VB Demo still works on the Client just fine. It is a 32-bit app. I’m confused why our custom application worked fine when 32-bit was False but not when 32-bit was made True. I would have figured it was the other way around.

I looked at several articles on configuring QODBC to work with 64-bit applications but that’s not exactly what we’re doing here. What is the simplest remedy to get our application with Enable 32-bit = True to work with the QRemote Server? I know the server is setup fine as VB Demo on the client works fine.

Solutions:

I guess you are using IIS.

When you set Enable 32-bit Applications = True, your IIS app pool runs as 32-bit.

You need to change the connection string to "QuickBooks Data QRemote"

When Enable 32-bit Applications = False, means it will run as 64-bit.

You need to use connection string as "QuickBooks Data 64-bit QRemote"

(0 vote(s))
Helpful
Not helpful

Comments (0)
Post a new comment
 
 
Full Name:
Email:
Comments:
CAPTCHA Verification 
 
Please complete the captcha below (we use this to prevent automated submissions).