Knowledgebase
[QODBC-Desktop] Microsoft Windows Vista Update Alert
Posted by brad waddell on 12 March 2009 05:21 PM

IMPORTANT NOTE: To see how to install QODBC and connect to QuickBooks for the first time using Microsoft Windows Vista click here: How to install QODBC in Windows XP/Vista

For QuickBooks users within the USA

With Microsoft’s release of Windows Vista, we wanted to ensure that all our users are informed about using QuickBooks on Windows Vista. First and foremost, USA versions of QuickBooks 2006 and earlier are not supported on Windows Vista. To use QODBC on Windows Vista you must be running QuickBooks 2007 Release 5 or higher (use Ctrl-1 while in QuickBooks to check your release level). R5 can be found on Intuit's website under QuickBooks Product Updates at http://www.quickbooks.com/support/index/ndxw_16_update.html

For QuickBooks users outside of USA

For non-USA versions of QuickBooks, this will mean that users will not be able to run QuickBooks and QODBC on Windows Vista until they upgrade to QuickBooks 2008 (or 2008/09 or higher) and QODBC v9. Because of the limitations of the SDK release used in QuickBooks outside the USA, QODBC cannot be used under the Microsoft Vista operating system unless QuickBooks 2008 or later is used.

You can view the QuickBooks announcements made regarding Windows Vista outside the USA for your region at:
Australia/New Zealand/Singapore: http://www.quicken.com.au/support/vistaUpdate.aspx
United Kingdom (UK): http://www.quickbooks.co.uk/store/en/quickbooks/vista_faq.jsp?pd=vista
Canada: http://support.intuit.ca/quickbooks/vista_faqs.php?pd=vista

QuickBooks qbXML SDK/Windows Vista Compatibility and QODBC

QODBC v7.00.00.214 (or higher) now works correctly with USA editions of QuickBooks 2007 R5 (or higher) and QuickBooks Enterprise Solutions 7.0 R5 (or higher) with the following caveats:

QODBC v9.00.00.253 (or higher) now also works correctly with all non-USA editions of QuickBooks 2008 (2008/09 or higher)and QuickBooks Enterprise Solutions 8.0 with the following caveats:

   - The Vista user account must have its User Account Control (UAC) set to On (as recommended by Microsoft).

   - Both QuickBooks and the QODBC application accessing the SDK should be run with standard user permissions (NOT elevated to run as administrator).

For further information about Microsoft Windows Vista, QuickBooks, and the QuickBooks qbXML SDK, see this article on the IDN website.

Note: For more about Vista and 64 bit and QODBC Update, please see: Vista/Windows 7 and 64 bit and QODBC

(711 vote(s))
Helpful
Not helpful

Comments (0)
Post a new comment
 
 
Full Name:
Email:
Comments:
CAPTCHA Verification 
 
Please complete the captcha below (we use this to prevent automated submissions).